Is anyone else on here unable to look at videos on youtube?

For every video I try to see on there it says missing plug in and I can't view anything on there, wtf? It started doing that last night for some reason.


0|0
2|3

Most Helpful Guy

  • -try installing the missing plug-in; there should be a link on there

    -try searching for updates for your computer

    -did you add any add-ons, such as adblock plus or noscript? If so, try disabling them

    0|1
    0|0
    • updating worked, I had a couple I wasn't alerted to that seems to have made a difference. no youtube would make me an even more miserable prick than I already am, thanks.

What Girls Said 2

  • Try:

    -Updating any plug-ins/add-ons

    -Updating the browser

    -Re-Installing the plug-ins/add-ons

    Which browser are you using?

    If you're using Mozilla, go to "Help>About Firefox" and it should tell you if it's up to date. Or, go to "Tools>Add-ons" and "search for updates"

    If you're on Google Chrome, you may need to go to "Extensions" and update them each individually.

    0|1
    0|0
    • i just got google chrome recently and I had some updates I wasn't aware of, updating seems to have fixed things, thanks.

  • The same thing happened to me yesterday. Youtube wouldn't let me play any videos.

    0|0
    0|0

What Guys Said 2

  • I can see them. Which is a shame cause I was about to show you a really good video from there. Oh well...

    0|0
    0|0
  • Works for me. You already fixed it, but do what Camilus said. lol

    0|0
    0|0
Loading...