HELP... pc freezes after opening a program?

3 days ago I had to leave and I pressed the shut down button from the start menu. I was waiting for the pc to close for 10 mins. I was in a hurry so I held the power button till it turned off. Today after 3 days I reopened it to find out that when I logged in the user, I clicked on chrome to open it and after some seconds the pc froze. The only way to close the pc isby holding the power button. I tried again but this time I opened the My computer icon. I could navigate normally. Then I tried to close Skype from running in the background but it froze again. I tried runnin in safe mode and everything was normal. Does this have to do with the power button?


0|0
0|6

Most Helpful Guy

What Girls Said 0

No girls shared opinions.

What Guys Said 5

  • Is your HDD filled with porn

    1|2
    0|2
    • Why download once I can watch online?

    • I tend to keep my collection of porn on my usb to avoid viruses and have them in separated categories Black Asian Petite Favorit- I mean a freind of mine silly me I don't watch porn it is immoral and wrong ☺️

    • Shhh dont worry I won't tell anyone :P

  • Turning off the computer while it's busy could cause damage to your hard disk. Do a check on that first.

    0|0
    0|0
    • Check on the hard disk? How?

    • Show All
    • Probably wasn't your disk then. Look at @kambo_trick3y 's answer :)

    • I solve it. I opened the tower just out of curiosity cause it was pretty loud. What i found was a thich layer of dust (around 1-2cm) covering the whole CPU. I unplugged everything and cleared the whole tower. It works perfectly now. Thanks for your help tho :)

  • Reinstall all your apps and try again

    0|0
    1|1
  • If it started recently... perform a System Restore... I think it should solve some errors

    0|0
    0|0
    • Should I call someone who knows? I was always afraid to do a system restore :P

    • Show All
    • What I the problem occured because I pressed the power button? Can the system restore fix that?

    • I solve it. I opened the tower just out of curiosity cause it was pretty loud. What i found was a thich layer of dust (around 1-2cm) covering the whole CPU. I unplugged everything and cleared the whole tower. It works perfectly now. Thanks for your help tho!!

  • You're virused!

    0|0
    0|1
    • Plus it's a pc. Should've got a mac

    • Show All
    • Especially all those parts

    • There's tonnes more down at the garbage dump :D

Loading...